Updating uBlox SARA-N211 on NB-IoT Shield (solved)

I found out that i need the newest firmware on my shield.
i’ve already recieved the tools to do it.

The boards i own are:

  • Arduino Uno
  • Arduino Leonardo
    The question is, is it possible to update with one of those boards?
    or do i need a Arduino ZERO or Serial USB or something like that?

Hi Paul,

You should be able to do this with an Arduino Leonardo.

Open the example sketch from the Arduino IDE.
File -> Examples -> Sodaq_nbIOT -> nbIOT_serial_passthrough

Kind regards,

Hello @Jan,

I’ve uploaded the sketch and he won’t update the firmware.
The image i get:

After some seconds i get the message: “timed out trying to establish connection”.

It’s the same result as when i tried to update with the GND to RSR with a cable.

What can i do?

Thanks in forhand,

Did you try this pin?


Hi Jan,

Yes i did… i put the cable in the GND and keep the cable on that point.
Then i pushed update…

How i setup my device for setup:

  • The shield is put on a Arduino Leonardo with code:
  • I bought a Serial to TTL device to connect with the SARA-N211.
  • I recieved the UEUpdater with firmware from JAN.
  • I connect the Serial RX to RX, TX to TX, GND to the RST Pin from the SARA-N211 shield.
  • Open the UEUpdater, Select com port from my Serial to TTL
  • Choose my firmware
  • Press update.

it just won’t update?
I thought maybe wrong labeling… so i tried to change the RX and TX, still no result.
What am i doing wrong?

Somehow the update worked…
my Serial to TTL needed to be on 3.3V instead of 5V.
Also i kept the reset pin to long on the reset.

The next problem is, the connection with All Things Talk still won’t work out of the box…
Therefore i use the example from the library nbIOT, example: “nbIOT_Humidity_Temperature_AllthingsTalk”.

Firmware version: 06.57, A07.03
When i use the Serial_passthrough sketch to talk to Ublox, i’m checking if i can get a connection.
Every AT-command works just fine till i use the command: AT+CFUN=1, i’ll get an error.
That will explain why the sketch to all things talk won’t work.
What can i do to put my antenne back on?