Update Firmware Version GPRSbee rev6b

Hi guys.

I’m using GPRSbee with a Mbili board to connect to a Rest API. I haven’t problems with HTTP versions but now I want to do it with HTTPS because our webserver is working with SSL.

I have been reading SIMCOM documentation and application notes on SIMCOM website: http://www.simcomm2m.com/Spain/module/detail.aspx?id=104. If I’m not wrong, sim800h support SSL encryption. Furthermore, documentation shows examples using it. Also, I have read an old post on forum and member wrote that was possible.

So I have started with HTTPS ‘application notes’ example. Every new HTTPS command worked well except one: AT+HTTPSSL=1. Everytime this command launch an error.

I have connected manually bypassing MBili Serial1-Serial on an Arduino sketch to use port window to write commands manually. Again, every command work except AT+HTTPSSL. I have tried AT+HTTPSSL=1, AT+HTTPSSL=0, AT+HTTPSSL? and everyone shows ERROR. So I think my firmware version doesn’t support this command.

If I send AT+CGMR, firmware revision is: 1308B05SIM800H32_BT. I have been searching over Inet and it seems that some BT firmware haves problems with SSL commands, so I have downloaded all required tools to update firmware to latest non BT version: 1309B11SIM800H32. I have downloaded SIMCOM upgrade tool too. I have followed all steps but I haven’t success. Anytime upgrade tools stablish comunication with SIM800. Upgrade tool is always “Waiting response…”. I have tried with Mbli Board, with a UartsBee (USB-Uart) and nothing happens, no response between upgrade tool and sim800h.

On rev6b schematic I see J3 connector with sim800 USB lines but I can’t find them on board. Where is it? I was thinking on try upgrade firmware through USB but I can’t find this J3.

Could someone explain me what to do to upgrade firmware? Does anyone get it?

Thank you. Regards.

Can you try this sketch, it does some of the sequence that is required for SSL. If I remember correctly, the AT+HTTPSSL command can only be sent after the GPRSbee is already put into a specific mode, otherwise you get an error.

I believe there may be other issues with the old firmware with regards to specifying the KEY.

Note: The initialisation for the GPRSbee is using the old API and will need to be changed.

Hi @GabrielNotman and thank you very much.

I have tested your code but same problem has happened. Every HTTP command works except AT+HTTPSSL=1. It shows ERROR as answer. AT+HTTPSSL=0 and AT+HTTPSSL? too.

I wrote an email to SimCom support and I have received response this morning. I couldn’t write here until now . As I suspected, It is firmware version problem. I attach a functionality/firmware version table that simcom support has send me.

As you can check on image, firmwares end with BT don’t support SSL function. My gprsbee response to AT+CGMR with “1308B05SIM800H32_BT” so, obviously, SSL isn’t supported.

If I want use SSL functionality, I need to change the firmware version. I have downloaded tools and firmware 1309B11SIM800H32 (the latest) but I can’t update it. Upgrade tool never start comunication with SIM800H… it is always “waiting” response from module. I have tried with Mbili Serial1, with UartsBee, but I haven’t success for now. I’m becoming crazy because I need SSL functionality to reach our real webserver HTTPS…

@GabrielNotman, do you know where is J3 connector? I can’t find J3 on gprsbee board. I have seeing rev6b schematic and I see that J3 has D+,D-,VBUS usb lines. Modules can be upgraded through USB lines instead of Uart lines so I have been thinking on use this lines and try luck to upgrade module.

Maybe, it would be a nice feature to put an USB on gprsbee board to upgrade them or maybe, give us an option to select firmware version when we buy them.

I would be grateful if someone could help me to change firmware version of gprsbee.

Thank you everyone. Regards.

I believe J3 is the three small pitch holes in the lower left corner (viewed from the top) of the rev6b.

I’m not sure which end is which though.

Thank you again @GabrielNotman. I see this three holes. Do you know anyone who could tell us which is which??