Trouble upgrading RN2483 firmware

Hi guys,

I did not manage the get the power consumption of the explorer below 2.5 mA . Now i read about a firmware bug which prevents the RN2483 to enter sleep mode.

So now i’am trying to upgrade the firmware using . Compilation works fine but after verification of the firmware entering the boot mode fails. I tried a power cycle / wait 10 seconds but this doesn’t help.

0 1 2 3 4 5 6 7 8 9
0x90 0x7F 0x00 0x20 0x00 0x00 0x00 0x00 0x0A 0x00
No response received at all!
The module did not respond in bootloader mode. Please unplug and retry in application mode.

Any other things i could try ?


Dear Sebastian,

Do you have the latest Arduino IDE and board files?
What is the revision number of the Explorer you have?

Looks like there went something wrong when the devices needed to switch after removing the current firmware.
Did you after the powercycle send the command “b” to begin in bootloader mode?


Hi Jan,

I’ve solved the issue in the meantime using another method. The method described here worked for me . I needed to make a small modification to the serial passthrough sketch , after that the microchip tool worked fine for me.

Best Regards

1 Like