Stop Uploading sketches Sodaq Sara R410M


I use the Soda Sara R410M. It worked fine for long time and the last 2 days cant upload my sketces.
I push the upload button, the bar seems be in 100% but never upload it.
After that i upload the reset sketch and the output is:
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
at cc.arduino.UploaderUtils.upload(
Caused by: Error touching serial port ‘COM5’.
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
… 5 more
Caused by: jssc.SerialPortException: Port name - COM5; Method name - openPort(); Exception type - Port busy.
at jssc.SerialPort.openPort(
… 6 more

I did reset the board (by pressing 2 times the reset button) but the problem remains.

Hi @sakxam

This line makes it seem like the COM port has already been opened by another program. Could that be the case? Perhaps a tool that monitors the communication or something like that?


When you press the reset button two times, and plug it into the PC using USB, there will be a different COM port (example COM6) visible in the Arduino IDE.
Have you tried uploading your sketch to the other COM port?

Yes you are right. I did it as you say and it works again.
Thank you very much Alex

Great to hear that @sakxam!