[SOLVED] Sodaq ONE V1 failing to receive upload


We had some training yesterday on the sodaq ONE V1 in which we were provided a sample program for P2P communication.

During the training I had no problems uploading the sketch to the boards.

Today however I’m unable to upload the sketch. The sketch compiles fine but when uploading it freezes with the progress bar at 100% and the message “Uploading…”
Here is a screen shot:

I tried uploading a different sketch (such as the “analogreadserial” example) and received this error:
Sketch uses 12072 bytes (4%) of program storage space. Maximum is 262144 bytes.
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:160)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
at processing.app.SketchController.upload(SketchController.java:713)
at processing.app.SketchController.exportApplet(SketchController.java:686)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2168)
at java.lang.Thread.run(Thread.java:748)
Caused by: processing.app.SerialException: Error touching serial port ‘COM6’.
at processing.app.Serial.touchForCDCReset(Serial.java:107)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:144)
… 5 more
Caused by: jssc.SerialPortException: Port name - COM6; Method name - openPort(); Exception type - Port busy.
at jssc.SerialPort.openPort(SerialPort.java:164)
at processing.app.Serial.touchForCDCReset(Serial.java:101)
… 6 more
An error occurred while uploading the sketch

I’m at a loss as to what has changed since yesterday. It says port busy in the error and I’m not sure why. I am not running anything else on those ports.

I have tried 3 different ports, no change.
I have tried resetting PC, no change

Please advise

Kind Regards,

It is definately related to the port being busy. When I plug in an existing sodaq one with a sketch already on it and try to open the serial monitor I get the error:

Error opening serial port ‘COM7’. (Port busy)
Error opening serial port ‘COM7’. (Port busy)
Error opening serial port ‘COM7’. (Port busy)
Error opening serial port ‘COM7’. (Port busy)
Error opening serial port ‘COM7’. (Port busy)

Solved! I wrote to Pin 5 by accident (setting it to LOW) which is used by the serial connection (SCL).

loaded a new program using pin 6 instead of 5.

good now

1 Like