SOLVED: Sodaq ONE died with "SAM-BA operation failed" during loading of sketch


I have uploaded the UniversalTracker sketch several times to my SodaqOne without a problem. The last time the upload failed… all I can remember was something like “SAM-BA operation failed”. Since now, the Sodaq One is completely dead… No USB comm port comes back up after unplugging, plugging, disconnecting litho battery, doing resets, changing computers… etc. What could be going on here?

Just to share the solution to my ‘bricked’ SodaqOne, i have found in another thread on this forum how to put the SodaqOne into boot loader mode by connecting the reset pin twice fast to ground. After performing this action, the USB comm port was detected again and I could successfully load sketches again.

1 Like

I’m having the same problem and tried resolving it with the reset. The board seems run as the port shows up in the IDE and I can get the board info, but it doesn’t show up in Windows when I plug it in and the LED doesn’t light up either. When I try to upload code, I get “SAM-BA operation failed. An error occurred while uploading the sketch”.
I’m new to Arduino, so excuse me if I’m overseeing something obvious.

Can you provide a screenshot of the error output?

Here,s the screenshot with the SAM-BA error

I can also include the full output if that helps.

It’s working fine on my desktop, but for some reason not on my laptop (which I need to use to work). I tried reinstalling everything, but no changes. Any help is greatly appreciated.

I’m also getting the following warning that I don’t quite understand:
Warning: platform.txt from core 'SODAQ SAMD (32-bits ARM Cortex-M0+) Boards' contains deprecated"{compiler.path}{}" {} {} "{build.path}/{archive_file}" "{object_file}", automatically converted to"{compiler.path}{}" {} {} "{archive_file_path}" "{object_file}". Consider upgrading this core.

I think I saw a similar issue once. There was some interference to the USB signal. This might have been caused by a faulty cable or an issue with the USB port or another device on the USB bus.

I would try another cable if possible and maybe also disconnect any other external USB devices.

Also double check that the correct SAMD board has been selected.