[SOLVED]N211: AT+CFUN returns ERROR after FM-update

I’m currently working on getting used to the SARA N211 on my NB-IoT Shield. At first it didn;t respond to a lot of AT commands, so I figured the firmware could use an update. After updating some commands work fne now, others are still not working (AT+NSOCR for example). Yet now I’m facing a new issue.

Whenever I try the AT+CFUN=1 command it simply returns ERROR. I see there’s a post with a similar issue here:

Yet the cause if this issue was a wrong SIM card. I’m using a Vodafone NB simcard that has worked fine on my R410M, so I’m guessing my sim card is fine?

My current FM-version is: 06.57,A09.06.

Do you have any ideas, because I’m out of them…


I found this piece of info:

AT+CIMI returns an ERROR for me as well, so it might be the SIM?
How does one check if a sim is either 1.8V or 3V?

Note: I’m using the T-Mobile SIM card that was provided by SODAQ in the NB-IoT Shield kit.The sim has worked on the previous FM version, so a sim issue can’t be possible right?


The N2 modules need to be updated to 06.57,A07.03 before updating to 06.57,A09.06.
We had issues with the N211 modules when skipping the 06.57,A07.03 that a lot commands returned ERROR.

This was solved by downgrading to 06.57,A07.03 and re-upgrade after this to 06.57,A09.06.

Can you downgrade and re-upgrade your shield?

Best regards,

1 Like

Thanks a lot @Jan, worked like a charm!