Sodaq SARA R410 - cant enter bootloader mode, board dead?

I am using this board for almost a year now, and I was programming it with PlatformIO without any problem.
This evening I tried something new: to flash the board with Bossa flash programmer and it went wrong, and now the board seems dead.
It does not show up as a COM port in Windows Device Manager. I tried to press Reset button twice to enter Bootloader mode, but it didn’t help: no blue LED blinking, nothing happening at all…
I am not able to upload anything at the moment, neither with PlatformIO nor with Arduino IDE, as my compuer sees not a single COM port available.
I noticed that an orange LED blinks twice when I attach the board through micro USB cable to my computer, and it blinks once when I detach it. I don’t know what that means?
What can I do now, did I completely killed it, or should I burn a new bootloader on it?

The bootloader resides in the lowest 8KB of flash memory on the board. If you tried using a direct programmer, it is possible that you either did a full flash erase, or you overwrote the section containing the bootloader.

Either way you will need to program the bootloader back on to the board.

You can find both a bin and hex version of the bootloader here:

(Note: The SARA board shares the same bootloader as the ExpLoRer, and you will also find a copy of these files in the folder where Arduino install the SODAQ board files.)

Hey Gabriel,

thanks for sharing this with me! So I just have to get an Atmel-Ice and burn the bootloader to the board.

@GabrielNotman could you help me with one more thing please? How do I attach the Atmel-Ice to the Sodaq Sara R410?

I found this for Sara AFF N211 Reburn bootloader on Sara AFF N211, I think for R410 it’s something similar to that.

Please follow the instructions in that post. They also apply to the AFF R410.

The 3.3V, GND & RESET pins are available on the Arduino headers.
The SWDIO & SWCLK should available on test points / pin holes on the PCB.


I managed to program the bootloader back to the board with an Atmel-Ice. It works fine now!

The problem was that I was experimenting with command line uploader (bossac), and accidentally erased the full flash.

By the way, I noticed that the bootloader I was using before this incident, was probably outdated!
I couldn’t upload any program to the board that was greater than 124KB (~50% of flash memory of Sodaq Sara). At the end of the upload process I got an error message saying
Verify failed
and the upload was never completed.

After programming the new bootloader back to my board, this issue is gone! Now I’m able to use the whole flash memory capacity, so I quickly refreshed the bootloader on the other boards too :slight_smile:

1 Like