SODAQ SAMD board 1.6.9 gives CRC doesn't match


I tried to upgrade from 1.6.8 to 1.6.9 and I am getting CRC error!

Something wrong with the file?



Same problem here too.

I tested Arduino IDE 1.6.12 with the standard (non-test) url:

The CRC appears to be fine. However, it is possible that you have a cached copy of 1.6.9 from a previous test version of that release.

If you are using Windows, the board files and the cached copies are stored in: /Users/USERNAME/AppData/Local/Arduino15

Try clearing the /staging subfolder and then try installing it again.

I removed the file from: C:\Users\Laptop\AppData\Local\Arduino15\staging\packages and this SOLVED the problem.

Thanks for the quick response.


I had the same issue with the CRC, and indeed by deleting the cached copy from the .arduino15/staging/packages directory I was able to install it.

I see on you also say we should use the test board url. Shouldn’t it be the URL without test?

What was also not entirely clear to me is the difference between the pages

A google search results in the “loraone” page, with instructions to use the test board url, and explicityly saying to use version 1.6.7. Won’t it be a good idea to state clearly at the top of the “loraone” page that these instruction are for the Sodaq One Beta, and that users should go to the non-beta page?

The /test URL contains the current official releases plus the current ‘test’ version. The other URL just contains the final release versions. The /test URL can be useful for getting a hold of the latest updates / fixes. These fixes do make their way into the official releases but this takes a bit longer.

The board installer/manager assumes that any release is final. So if the current ‘test’ version is updated, this causes the CRC check to fail. The board manager does not download a release if it has a matching (based on the name) copy. Additionally, the board manager compares the CRC of the cached copy with that of the updated CRC (for the updated, but identically named version).

Those help pages need updating. Also, due to some minor hardware changes there is a different board entry for both the SodaqONEe and the SodaqONE BETA.