Sodaq One v2, connecting to TTN: "LoRa OTAA init failed!"

Last week I received a brand new Sodaq One v2 to play with. So I tried to connect it to TTN to demo some GPS tracking.

I followed every guide and everything seems to be ok, but I still get this “LoRa OTAA init failed!” message in the serial monitor. If I take a look at my gateway (lorank8) traffic in the TTN traffic monitor I do see a join request but nothing happens after this.

These are the current Sodaq settings:

GPS (OFF=0 / ON=1) (gps=): 1
Fix Interval (min) (fi=): 15
Alt. Fix Interval (min) (afi=): 0
Alt. Fix From (HH) (affh=): 0
Alt. Fix From (MM) (affm=): 0
Alt. Fix To (HH) (afth=): 0
Alt. Fix To (MM) (aftm=): 0
GPS Fix Timeout (sec) (gft=): 120
Minimum sat count (sat=): 4
Num Coords to Upload (num=): 1

On-the-move Functionality
Acceleration% (100% = 8g) (acc=): 0
Acceleration Duration (acd=): 0
Fix Interval (min) (acf=): 1
Timeout (min) (act=): 10

OTAA Mode (OFF=0 / ON=1) (otaa=): 1
Retry conn. (OFF=0 / ON=1) (retry=): 0
ADR (OFF=0 / ON=1) (adr=): 1
ACK (OFF=0 / ON=1) (ack=): 0
Spreading Factor (sf=): 7
Output Index (pwr=): 1
Lora Port (lprt=): 1
DevAddr / DevEUI (dev=): 0004A30B001C2AD6
AppSKey / AppEUI (app=): 70B3D57EF0004C60
NWSKey / AppKey (key=): 154C6F4D8D3F77920E3F1924E63B866E
Repeat Count (rep=): 0

Cayenne LPP (OFF=0 / ON=1) (cay=): 0
Temperature Sensor Offset (temp=): 20
Status LED (OFF=0 / ON=1) (led=): 1
Debug (OFF=0 / ON=1) (dbg=): 0
Initializing LoRa…
LoRa OTAA init failed!
** Boot-up completed successfully!
The USB is going to be disabled now.

Anyone any suggestions?


Hello Jasper,
you settings are looking good for me.
The only setting that differs to mine is sf=7.
I had same problem as you have long time ago.
Fiddling around I succeed with sf=10,
Never tried sf=7 again.
Please do not ask why. I do not know.
Just try it :-/

TNX mateng,

Tried this, didn’t work. Even after few hours. Anyone else?

Update: Got OTAA up and running yesterday. I shutdown my own gateway (Ideetron Lorank8) and moved into range of another gateway. BAM! instantly the board managed to activate itself via OTAA. So far so good.
After a few hours being in reach of my own gateway the board stopped sending data…
Could the combination of the Lorank8 and the Sodaq1 be the issue?

Good morning,

Can you try to send an ABP with ACK?
If you cannot recieve an ack and no otaa init then its maybe a firewall issue?

When the board did stop sending data, did you check in the console if the lorank was still connected to TTN?

Maybe it helps when you reset the lorank to factory settings, and reinstall the TTN forwarder.

Hope you will solve it soon!