Sim Network error

Hi all,

I have a Vodafone (SARA AFF R410M) iot starter kit in The Netherlands since August and although everything started and worked almost seamlessly out of the box there were sometimes issues with the sim card not connecting to the network but after a reset of the board all worked well.

However now since a couple of weeks I cannot seem to connect at all.

When I switch on the board it starts up then displays the temperature and the msg uploading but after a while shows “Error couldn’t connect to network.”

I have tried resetting the board, removing and re-inserting the sim card, taking power off the board but to no avail.

What else can I do or who do I need to contact to help resolve this?


Dear Colin,

We are sorry to hear you are encountering these issues, this is a known problem which unfortunately sometimes happen. The only option is to replace the board for a new one.

Would it be possible for you to send a email to: Here we can discuss the free replacement of the board and the address for shipment.

With kind regards,
Sander Veldwijk