SARA SFF R412M initial start

Got the module faster than expected (thanx!) but got stock in the first connection.

Some questions:

A) Using Manjaro, connected the module.
LED startup blink scheme is: 2x flash yellow, 3x flash blue, stable yellow on, stable green on.
When using lsusb, no new module is visible. What can I expect here?

B) Using Arduino 1.8.12 - tried to follow the Tutorial - but got stock.
What should be used for the SFF module: “Board SFF” or “Board SARA”? The module is names “SARA SFF” :wink:

Which serial connection should be used /dev/ttyS0 or /dev/USB0. No reaction on any serail interface - maybe related to A)

C) Tutorial mention (maybe) update the firmware. At least the firmware and the tool “EasyFlash” ist necessary. How to obtain them?

I can imagine it’s a bit unclear.
We first had the SODAQ SARA board, later re-branded in the webshop as SODAQ SARA AFF.
Later we added the SODAA SARA SFF, in the Arduino manager you should select the SODAQ SFF.

Send an email to info at sodaq dot com here we have a reply ready with the latest firmware files.
The EasyFlash tool is only available for Windows.

The manufacturing company loaded a sketch to verify the board is working, a stable LED on the end means the board passed all software checks.

Best regards,

Thanx for the fast response, Jan, but I need to come back to make the problem clearer:

A) On command line using “lsusb” command while SFF board is connected but no extra USB device is shown. Is there a Vendor and Device ID that can be expected with connected SRA SFF module?

B) Okay, using “SARA SFF” in Arduino now. No connection can be established with Arduino, too. This is expected because USB is not shown in A)
Nevertheless I tried in Arduino: Tools | Get Board Information, and received:
BN: Unknown Board
VID: 0451
PID: 3410
SN: Load sketch to get…

So we have no USB recognition at all.

C) Windows is available, too, for development but not preferred. Will the EasyFlash Tool be available upon email request? I am asking this because there seems to be no download capability at uBlox side.

Best regards

This is probably a drivers issue, can you see if you can find and install drivers for the Arduino Zero board?

Yes, there is an reply ready to send you the tool and files.

Hi, found the problem - USB cable was broken :roll_eyes: download of “Universal Tracker” was possible but no GPS fix, yet. Is there a SIM card necessary for first fix? For now there is no SIM card installed.
Have to check more on that.

Hi @ralph,

There is no SIM required to get a GPS fix.
However getting a GPS position indoors might be hard. Put the device next to a window to get a position.

Best regards,

Hi Jan,

tried several version of the Sodaq Universal Tracker (, but with none of them a GPS lock was possible. The red LED was constantly active.
Do I need to make some settings when the firmware is downloaded?
Best regards

Hi @ralph,

We have 4 versions, of which 3 are for the SODAQ ONE, V1, V2 and V3.
For the SFF only the Universal Tracker is compatible.

Program it in Arduino with SODAQ SFF selected.
For the R412M you need battery connected. The battery and USB are allowed to be connected at the same time. The battery will be charged by the USB cable.

In the bootup menu, you need to insert your SIM settings.
When there is no network selected the device is blocking, the LED will stay red and in the boot menu.

If you still have issues, please enable the debug dbg=1 and share the logfile.

Best regards,

Hi Jan,
yellow load indicator for battery works.
Programming seems to work but no access via arduino build-in serial terminal somehow.
By using “moserial” on /dev/tty/ACM0 115200,8K1 a Command help list is printed. Remember there is no SIM card yet inserted. Is it correct that we cannot see any valid response to the following commands?
Show IMEI (SI):
Show CCID (SC):
Show Module version (SV):

Is there a chance to see if the GPS got locked? Cannot see a command for that…

Best regards