SARA R412M not responding to anything

Good evening, I am facing a weird issue. I have a ublox board, the C030 R412M, which includes the SARA R412M cellular modem. I have been using it with no problems, even though I was never able to connect to NB-IoT. However I downloaded another mbed studio programm that actually only worked with the GNSS module, and supposedly put the whole board to sleep and back to active again after a while.
After I was finished with the task that included this programm I switched back to trying to use the cellular modem but it seems like it is now dead. No response to any AT command, not even through ublox m-center.
Has anyone faced anything similar? I tried to make the PWR_ON low for a while as suggest in other threads to wake up the modem from deep sleep mode but to no avail. Does anyone know how I can make the modem active again? Or in the worst case scenario how can I be 100% sure that I have damaged the modem beyond repair somehow?

Thanks in advance

Hi @SotirisKordas,

These forums are for SODAQ products bought on
We sell boards with the R412M from ublox, but we know nothing about the C030 board.

The R4 series have two power pins, the first pin gives power to the ublox mode. You should just leave the power on while testing. When you require a low power solution this pin can be turned off.
The 2nd pin you can toggle the power. When you toggle this pin it will go either on or off depending on the current state.
You should check which pin is your PWR_ON.

Hope this helps you.

Best regards,

Thanks for your reply,

I understand that you only support sodaq boards, I just thought someone might give me some insight to details about the cellular module itself. I will try the suggested solution, although I think that it might have been damaged. So the PWR_ON pin is the second pin you refer to, if I understand correctly? What is the name of the first pin though?

Thank you very much

Best regards,

Ho Sotiris,

For generic ublox support please refer to the ublox forums.