Sara R410M default settings


I recently got a Sodaq Sara R410M that someone tinkered with before me, so I have no idea which settings the preowner made. Unfortunately, I couldn’t find anything about a way to get everything back to factory defaults, so it seems like I’ll have to figure it out manually?
I’m trying to connect it to the German 1nce.
Here’s some information I found helpful:

I tried to follow that guide, but I think I might have messed up something by myself. In order to set the correct band (band 8), I tried setting at+ubandmask=0,8, but then I realized that this wasn’t the option I was looking for.

Now, to my problem:
It seems like some settings are messed up. The main issue right now is that “AT+COPS=?” returns “+CME ERROR: operation not allowed”. As far as I can tell, that should work.

I don’t really know where to start, so any help is appreciated, even if you just point me in the right direction. If you need more information, I’ll happily provide it.

Hi @username1

The correct command is “AT+COPS?”, without the = sign. You can reset the settings by using AT+CFUN=15. I’m pretty sure this resets the SIM as well. Hope that helps!


Hello Michael,

thank you for your help.
Are you sure about that? According to the documentation, AT+COPS=? and AT+COPS? are just two different things. The first should return a list with all available networks and the second just asks for the settings that were made with AT+COPS=.
Also, when I request a network list in m-center, it sends the AT+COPS=?-command and then aborts, because it gets that error message.

Should AT+CFUN=15 also reset the settings that were made in non-volatile storage? To me, it doesn’t seem like it does.

Yeah, you are right. I didn’t know there were 2 different Commands. I tried “AT+COPS=?” now and it worked. Altough it took some time (about 1 minute).
Tried the “AT+CFUN” command myself now as well, most parameters got reset. But a couple non-volitile ones remained, so you were right there as well.
I did some datasheet digging and all reset options with the CFUN command said : “with detach from network and saving of NVM parameters”, so that’s a bummer.
I did find commands like this one though:

It might be possible to restore all of the settings to factory settings by entering this and similar commands for the different modes. Didn;t really find a total reset unfortunately.
Uploading a new firmware might do this though.


As expected, restoring the MQTT-Profile didn’t make any difference.
Reflashing the board did the trick, though! Thank you.