SARA R4 410M rev 3 - USB port fried?

Hi Jan,

I’m testing the SARA R4 410M rev 3 in Myanmar, yesterday we had 3 power surges, after that the Arduino IDE stated: “Couldn’t find a Board on the selected port. If it is correct, try pressing the board’s reset button after initiating the upload. Board at /dev/cu.usbmodem1421 is not available”. The day before /dev/cu.usbmodem1421 worked. I also changed cables.

On the macbook terminal console: ls /dev/tty.*

So /dev/cu.usbmodem1421 is not in there. Any clues ?

Krgds, Charles

You could try and connect to your PC using a FTDI breakout cable. This will bypass the serial converter on the board.
If it connects that means the serial converter on your board is dead. If it doesn’t, you probably have a bigger issue than just the serial converter.

Good luck!


I’ll give it a try when I’m home again.

Will this work ?
The FDTI breakout cable is available in 5V and 3.3V. Which one to use ?
There are 6 outputs on the cable. In case of 5V, I guess the line-up (FDTI = SARA R4) is:

But what is the equivalent of RTS and CTS ?


I’ve tested a FTDI cable to read serial data from my SODAQ board before. Here’s a connection example:
FTDI Red - SODAQ 5V or SODAQ 3V3 (depending on your FTDI cable)

Yet I haven’t tested uploading to the SODAQ yet using RTS and CTS. I will let you know if I manage to do that. Judging by the fact that the SARA board has Arduino compatibility, I assume it works the same as the Arduino Uno and you could connect RTS to reset with a 100nF cap in series. Or just press the reset button manually and let go as it start uploading. CTS can be left N/C.

Hope this helps!



With an FTDI cable you can NOT program this microcontroller.
You can use it to read from the external Serial.
This is good to put the microcontroller into sleep and have some debug output running.
If you use this use the 3.3V and only connect RX->TX, TX->RX, GND->GND.
Our board is NOT Arduino UNO compatible but Arduino Zero.

What you need is an Atmel ICE to bypass the USB of the SAMD microcontroller.
And an TAG Connect cable to connect it to our SARA board.

But before we need to buy external tools. Reboot your pc.
Connect the SARA with the usb cable to your pc and double press the reset button.
If this causes the LED to fade, then the Arduino bootloader is still there.
You should get a new com port to program the microcontroller.

SARA rev3 has two usb ports, do you use the correct port?
The one next to the sim card slot?

Let me know if you get it back to life!

Best regards,

Hi Jan,

Yesterday I went to Photon in Mandalay, great guys, skilled and very very helpful. They had a FDTI board (LED to see up/downloads) and did about 8 tests (3.3V/5V and even trying RX->RX). Also double press the reset button (so the SARA LED faded), a new port arrived but still no connection available when starting to upload a sketch.
I have the SARA rev3, but also that one is not responding.

Photon didn’t have a Atmel ICE available and a TAG Connect cable availabe. So I couldn’t proceed.
I’ll bring in this damaged board and FDTI (board and cable) when I’m at SODAQ, let you decide what to do next.
Thanks for all your help, Jan and Michael !!

Kind regards from Mandalay (Myanmar)

Hi Jan,

I took some time to redo your ‘double press the reset button’, now the reset worked when using the original SARA files from the SODAQ workshop. Finally I found out that my version of make.cpp corrupted the functioning of the sketch resulting in a ‘USB port not found error’.

This is an interesting learning moment. I can continue now.
Thanks. Case closed.

1 Like