R412M no longer finds LTE-M networks, only 2G

I’m new with the Sodaq line, and I just purchased a R412M SFF for beta testing - I’ve have previous developer experience with the MKRGSM. I followed the examples on the Sodaq support page to begin. The AT passthrough sketch worked well with Telus, the LTE-M iot provider I am using in Canada. I utilized the settings for Monogoto LTE-M, which worked fine. I was able to register with the carrier, send SMS messages, and all the normal functions.

I then set up an MQTT server, and went back to the Sodaq R412M SFF. I used the mqtt_test sketch example from the Sodaq_R4X library in the Arduino IDE. I uncommented the custom provider, and used the default settings except for the correct Telus APN (m2m.telus.iot), that had worked previously with the Passthrough sketch. Everything compiled properly, but I would get “network connection failed” on the monitor, and could go no further. Uncommenting the debug feature showed that no provider was found, the AT+CSQ? command failed (responding 99,99 multiple times until failure).

I then went back to the passthrough sketch, and compiled and uploaded it onto the board. I found the previously disabled power saving functions (PSM/eDRX) were re-enabled, and had to be disabled again. However, now I could not establish any connection to Telus. Using identical commands, I could not get a valid CSQ nor attachment.

I downloaded m-center, which confirmed I had the most recent Ublox firmware version (M0.10.00,A.02.14) and the SIM was ready. However, when I did a scan for Network Operators, I could not find Telus, nor any other LTE-M listed. Only one network was shown, which is the lingering Rogers 2G GSM network. Changing SIM cards did not change this scan, and SIM cards are confirmed as active.

I suspect that somehow, the LTE-M functionality of the Ublox modem has been disabled somehow. I cannot, however, figure out how to correct this issue. AT+URAT=7 does not assist, nor does any other status command show a problem.

Has anyone encountered this - and is there any way to correct it, short of throwing out the board and starting again?

Thanks very much.

Solution Located in the MNO Profile. Automatic selection no longer works, but for Telus LTE-M:


Appear to be the correct settings.

1 Like