Problems with ExpLoRer board. Not communicating with RN2483


I finally found the time to unpack my ExpLoRer board. I connected it to my macbook and loaded the example sketch to upload the temperature via LoRaWan (TTN).
After entering the right keys from my application it worked directly. (besides that the method LoRaBee.setSpreadingFactor(9) not is acceped)

But the I made a change in the sketch to debug the temp. From that moment I can upload the sketch to the board but it doesn’t connect to TTN. I get different messages from “Connection to the network failed” and “There was no response from the device”. There’s no battery on the board and unplug en plug it again doesn’t solve this. Now i keep getting:

There was no acknowledgment sent back!
There was no acknowledgment sent back!
There was no acknowledgment sent back!
Connection timed-out. Check your serial connection to the device! Sleeping for 20sec.
Oh No! This shouldn't happen. Something is really wrong! Try restarting the device!
The program will now halt.

I have similar ‘problems’ with my Sodaq Mbili , after uploading a new sketch I have to unplug the RN2483 bee from the board and plug it back. From that moment it communicates again. But I can’t take of the RN2483 from the ExpLoRer. And maybe this is a different issue.

Arduino IDE: 1.6.12
Board file: SODAQ SAMD Boards 1.6.9
Lib: Sodaq_RN2483 1.0.2

I have no idea what the firmware version of the Microchip is. On the Mbili it is 0.9.5 (and I can’t get it updated).

But now I am stuck. Any advise?

Thanks in advance!


Nobody any idea? I can’t do anything now with my board…

Hi Oscar,

The message “There was no acknowledgment sent back!” means that the RN module doesn’t get a confirmation that the message is received by the gateway. Are you in range of an gateway?

I have updated the sketch, now by default it is sending without ADR and without ACK.
This is compatible with all networks.

The Explorer was shipped with version 1.0.1 the difference between 0.9.5 is that 0.9.5 doesn’t support OTAA.
As long as you use ABP on the LoRaBEE you shouldn’t have any problems.

Could you let me know if the new sketch on the support site works for you?



First I didn’t the board to connect. No com port on Mac and Windows. Now it is back on Windows. So I tried the new sketch:

First upload: I start sending:

Communicationto LoRaBEE successfull
Successful transmission
Successful transmission
Successful transmission

The I modified the code (sleep longer in loop) and then upload the sketch:

Communication to LoRaBEE failed!
There was no response from the device.

This is exactly what happens with my Mbili. From the second upload on I have to remove the LoRaBee after every upload. But on the ExpLoRer I can’t do that?
I disconnected the board for few minutes (no battery) but nothing helps to communicate with the RN2483

Thanks for your answer.


Info when compiling and sending:

Sketch uses 29,400 bytes (11%) of program storage space. Maximum is 262,144 bytes.
Atmel SMART device 0x10010000 found
Device       : ATSAMD21J18A
Chip ID      : 10010000
Version      : v2.0 [Arduino:XYZ] Jul 25 2016 21:49:22
Address      : 8192
Pages        : 3968
Page Size    : 64 bytes
Total Size   : 248KB
Planes       : 1
Lock Regions : 16
Locked       : none
Security     : false
Boot Flash   : true
BOD          : true
BOR          : true
Arduino      : FAST_CHIP_ERASE
Erase flash
done in 0.672 seconds

Write 29720 bytes to flash (465 pages)

[====                          ] 13% (64/465 pages)
[========                      ] 27% (128/465 pages)
[============                  ] 41% (192/465 pages)
[================              ] 55% (256/465 pages)
[====================          ] 68% (320/465 pages)
[========================      ] 82% (384/465 pages)
[============================  ] 96% (448/465 pages)
[==============================] 100% (465/465 pages)
done in 0.375 seconds

Verify 29720 bytes of flash with checksum.
Verify successful
done in 0.047 seconds
CPU reset.

Hi Oscar,

Can you connect the Explorer to your pc with a usb cable and double press the reset button?
This will put the board into bootloader mode.


Sorry in the meantime I updated my answer above…

We also have the same issue. Some of the RN modules are not responding anymore when they are busy and you upload a sketch.

With the Mbili you can take off the USB / switch the on/off button or remove the lorabee.
With the Explorer you can just unplug the usb cable. This will reset the lora module.
The sketch is still on the microcontroller. When you replug the usb you can open the serial monitor directly.

With explorer revision 5 and up we added a reset line from the microcontroller to the RN modules.
This will solve the problem with LoRa if it hangs after an upload of a new sketch. The reset is attached to an I/O pin.

Unfortunately this is here not the case. I have to disconnect the board for several hours (didn’t measure how many) to be able to communicate with the RN again.

Wouldn’t it be possible to connect some pins by hand with a wire as workaround? This situation makes developing an application very hard.


Hi Orcar,

Yes in this datasheet you can find the reset pin of the RN2483

Connect it with a pull-up resistor to an I/O pin and then you can reset it any time in code.

Let me know if this solves your problem.


Hi Jan,

I’ll try and let you know the outcome.