Problem with Sodaq One!

Hi eveyone !
I’m a newbie and I have a problem with the program for Sodaq one.
Can you fix the problem ?

Could you specify which version of the Arduino IDE, which version of the SODAQ board files, and what operating system you are using?

I am using IDE 1.6.12, SODAQ board 1.6.8 and window 10 64bits !
Thanks for your response !

Yesterday, I did a clean install with the IDE v1.6.12 and SODAQ Samd boards v1.6.8.
I did not encounter this issue.

It appears that there is some problem with the SODAQ Samd board file installation.

I would recommend trying the following:

  1. Can you check under Tools->Boards whether the list of SODAQ Samd boards are showing (there should be the Autonomo, SODAQ One and others).

  2. If you go to File->Preferences there is an option to turn on verbose output during the compiling and uploading stages. If you enable the compiling option, you should see some more detail about what the issue is.

  3. I would recommend reinstalling the SODAQ Samd board files, you may need to remove or uninstall the existing files. All of this can be done through the boards manager (Tools->Boards->Boards Manager).

Dear sir !
Can I have your Facebook or Email?

I can be reached on my old Sodaq email address:

gabriel at sodaq dot com

1 Like

Thank you !
But I follow you to work with the link
but its also get the issue !

Are you able to compile other examples or even a blank sketch for the Sodaq ONE?

I have tried compiling the example from that library using the IDE v1.6.12 and SODAQ Samd boards v1.6.8. I also tried a separate sketch that had the same includes. I didn’t encounter the issue you seem to be having.

It would be useful to have the whole output from the compile log, as the above image only shows the last 25 lines or so. You can copy and paste from that window. Feel free to send it to me via email.

I believe that there might be some issue with your installation. I would recommend uninstalling and deleting the settings folder (on Windows /Users//AppData/Local/Arduino15), and then doing a fresh install.

Thank you very much !
I am working with this

@GabrielNotman : Excuse me again sir!
Why my gps take a long time to wait for fix …time out : 900000ms ?
Thanks for your respone !

There are several threads on this forum that discuss the time it takes to get a GPS lock.

This can be conditional on things such as which antenna is being used and whether you are in an indoor or outdoor location.

Thank you sir !
The gps worked already. But can I have your email or facebook ?
I’m a student in Viet Nam and I do not have much materials about sodaq or lora. But I want to make a new thing for my country.

My email is gabriel at sodaq dot com.