OS X Catalina does not detect SODAQ SFF Boards (R410M and R412M)


After upgrading to OS X Catalina my laptop stopped recognising the connection via USB of the SODAQ SFF Boards.

I first thought the device couldn’t be found on Arduino IDE, but then I realized the laptop was not able to find the board.

Any suggestions on how to solve this?


HI @escj,

Did you install the SODAQ board files?

Best regards,

Thanks for replying @Jan

I have all those files installed. In fact, I removed them and reinstalled them in case any library got deleted by mistake. But the boards still do not show in the screen.

Not only is Arduino not detecting them, but either the computer itself.

I tried different cables, and other computers as well. Also, other Arduino boards work normally.

Best regards,

Hi @escj,

Can you try these two options?

  1. Try double pressing the reset button to get the board into bootloader mode.
    Check in the Arduino IDE if the board gets recognised.

  2. Can you install the Arduino SAMD Boards for the Cortex-m0?
    Search for “arduino m0”

Our boards are based on the same microcontroller, hopefully the official Arduino Boards + their latest driver will fix the issue.

Best regards,

Thanks again @Jan

I tried both and still could not solve it…

Hi @escj,

Can you check the board on another pc and with a difference USB cable?

Best regards,

Yes, I did try different USB cables and different computers. However, I currently don’t have access to other PCs, only a couple of MacBooks running the same OS as my computer…