Not recognizing Sara AFF R410M board

Hi everyone,

I am using since a couple of months the Sara AFF R410 board and never had an issue with it.
Yesterday while testing out some code and trying to upload it on the board I had some major issues.
when connecting the board I only get a red led.

To start off, when connecting the board to my computer (desktop) it showed 2 COM ports instead of one in the arduino IDE and device manager. (without showing the name of the board wich normally was the case).
When I then try to upload the code on those COM ports I have an error telling me “the device is not found”. (tried both of the COM ports)
I then reinstalled the drivers and tried again and got the same issue.
I pushed the reset button twice to get it in bootloader mode I see the blue led blinking but it doesn’t change anything I still can’t upload code and I still see 2 COM ports.

Then I tried it on another computer (pc). There it doesn’t even show the device in the serial ports I just get a grey “port” in the Arduino IDE. Also tried to put it in bootloader mode even though the blue led is blinking I don’t see the device on the Arduino IDE and the device manager.

Is there something I can try to fix this ?

Hi @tsoundi ,

Do you use the correct USB port?

The board has two USB port, the one next to the sim slot is required to upload new sketches.
The other USB port has indeed two COM ports, to directly send AT commands to the ublox module and to perform an update.

Best regards,

hi @Jan,

Oh my god, I feel really dumb.
I indeed used the bad usb port I didn’t even think about that.

Thank you very much for the fast answer !

Hi @tsoundi,

No problem, you’re not the first and will not be the last with this issue.
It was nice that you provided enough information to indicatie the problem fast :slight_smile:

Have fun with the device.

Best regards,

1 Like