Netwerk offline? (solved)


I can’t connect with the NB-IoT network, I already had a connection, only now it doesn’t connect anymore.
The result i get is:
> -1
> -1
> [rdResp]: ERROR

How can i fix this?

What i’ve tried since this error:

  • Firmware reset (FW 06.57-A07.03)
  • New code upload
  • Just testing the NB-IoT module

This returns always the CSQ of 99,99

What’s the problem?

Can someone please say what the current status of the network is?
Connection was lost here yesterday 10:30. I suspected it might be due to not having updated the FW on the SARA-N211 module. But as the FW update isn’t working, I would like to make sure that the network is OK before investing a lot of time in the update.

Same problem here,
since yesterday no connection and still not today.
Also dieing to know the status!

Since when is your connection not working anymore?

AT+CSQ always returns 99,99, AT+CGATT? returns 0 so there is no connection. Two boards here were working just fine until 10:30 or so yesterday, then I noticed them retrying and the AT+CSQ 99,99.

On Monday I saw an error on the console with the word ‘exceeded’ in it, but I am not sure at all about that, I was busy with other things and planning to get back to that message the next day.

Maybe someone else has noticed error messages, if so, could you please post them?

Yesterday, T-Mobile NL migrated from OceanConnect to Nokia Impact, maybe that’s the root cause.


Where did you find this issue, and are they working on this problem?

Thanks Felix. Is there a place where information like this is posted? Other than T-Mobile message boards (I have no access to those).
I’ll have to decide to wait for the network to become available, or proceed in another way which will take a day, so if anyone knows when this will be solved, it would be greatly appreciated.

I was informed by t-mobile, I suggest to check their websites:

P.s. I already migrated my SODAQ boards (requires some firmware changes) and have my SIMs converted by T-mobile.

P.s. According to my info, the ‘old’ system will be up& running until end-of-April. So, no idea why you have no connection anymore.

So you dont know what we should do right now?

I guess I’m missing something, but I can’t find the information on the SIM conversion. Could you be so kind to repost that here?
In the mean time I’ll continue to troubleshoot the firmware upgrade further in hopes that this might help with the connection issue.

Contact t-mobile, there will be an installfest on April 25.

For the moment (on my configuration) it is possible to connect by putting AT+NCONFIG=“CR_0354_0338_SCRAMBLING”,“TRUE” in the initialization (instead of FALSE).
Not sure how the SARA N211 firmware update affects the situation, all messages sent from the one board that I updated time out. The other one can connect and send messages. Both display SW 06.57.

Indeed, this is one of the things that changed, see:

Scrambling is a network feature, independent of modem type or FW version.

We cant open that link, we are nog allowed.
Where can i change this in my library from sodaq?

extract from t-mobile forum, posted yesterday.

Thanks Felix,

It worked!!!

it is working again!