nbIoT passthrough doesn't work for SFF R410M

Hi, the nbIoT passthrough example code does not work on my SFF R410M rev2. I uncommented #define R4XX in the example, compile & upload are all fine, but when I use serial monitor with baud 115200, I cannot get any response from the serial link.

sodaq nbIoT lib version is 2.0.1, Arduinio version is 1.8.5, sodaq GPS

I did try to print the infor, the code went in the DEBUG.STREAM available then waiting for the MODEM.STREAM and no response from there.

I also checked that the example is writing is PowerPin 27, TogglePin 52, which does not match the website description D49 and D15. I tried the example on the SFF support page as well, no luck either. BTW, pin 27 is the powerpin for AFF R410.

The header file variant.h in the .arduino15/packages/SODAQ/hardware/samd/1.6.19/variants/sodaq_sff has the pin number 49 and 15. I am suspecting that the example code isn’t reading the correct board model, or the pin number so the SFF nb module isn’t properly powered on?

I have few SFFs and all of them have the same issue, very small chance it is a hardware problem.

The example for onboard LED doesn’t work either.

Could you please help to solve this issue? Thank you.

Hi @Ying,

I have just tested the nbIoT passthrough example from the library.

This is correct, this is the only change you need to make,

Did you compile it for the SFF board and NOT for the SARA board?
The Serial monitor indeed needs to be on 115200, do you also have Carriage Return and New Line enabled? (Both NL & CR)

Did you download the latest SODAQ Boardfiles? See:

The original example can also be found here:

Best regards,

Hi Jan,

It works now on some of the SFF boards that we have, one doesn’t work still. Guess it is a hardware issue for that particular one. Anyways, thank you very much.


Hi @Ying,

If all boards work and one doesn’t then it’s indeed most likely an hardware issue.
Please contact the webshop about the issue, they will send you a replacement.

Best regards,