Nb-iot shield csq always 99,99

My nb-iot shield has an strange problem. It was able to connect to t-mobile nb-iot. But now nomore, the following are the at+cmd and response:

nbiot–> OK
nbiot–> OK
nbiot–> OK
–>nbiot: "AT+NCONFIG?"
nbiot–> OK
–>nbiot: "AT+CFUN=0"
nbiot–> OK
–>nbiot: "AT+NCDP="
nbiot–> OK
–>nbiot: "AT+CGDCONT=1,“IP”,“oceanconnect.t-mobile.nl”"
nbiot–> OK
–>nbiot: "AT+CFUN=1"
nbiot–> OK
–>nbiot: "AT+NBAND=8"
nbiot–> OK
–>nbiot: "AT+COPS=1,2,"20416""
nbiot–> OK
–>nbiot: "AT+CSQ"
nbiot–> +CSQ:99,99

The CSQ is always 99,99.

Then I checked the neuestats by sending:
nbiot–> NUESTATS:RADIO,Signal power:0
nbiot–> NUESTATS:RADIO,Total power:-32767
nbiot–> NUESTATS:RADIO,TX power:0
nbiot–> NUESTATS:RADIO,TX time:0
nbiot–> NUESTATS:RADIO,RX time:3602
nbiot–> NUESTATS:RADIO,Cell ID:0
nbiot–> OK

Signal Power is always 0.

Any ideas?

When you don’t get a signal for a long time, the best option is to send the reboot command and start over from AT+CFUN=0

Maybe an firmware upgrade is needed to connect to the network.
What module with firmware version are you using?

Follow these steps to upgrade the firmware to the latest version: http://support.sodaq.com/sodaq-one/firmware-upgrade/

Best regards,

I’m trying to upgrade the module by following the instructions with crowduino m0. But the UEUpdaterUI is always giving a timeout error. On the module itself indicates it is “SARA-N201, 02B-00”, while I’m using AT cmd to get info from the module are:

<Neul Ltd; www.neul.com/
<Neul Hi2110

I couldn’t find any info from www.neul.com. ATI9 should be supported by the sara module. Is this a module from neul different as the standard sara module?


Hi Kyle,

It seems from the AT+CGMR reply that you’re on an older version of the firmware (V100R100C10B656), is that correct? ATI9 is only supported in later version of the firmware.

What are the errors that you’re getting when trying to update the firmware (or at what stage of the uploading progress)? Also, just to double check, did you select the right module (SARA-N201) when selecting the firmware files (in UEUpdaterUI)?

Important to note is that the SARA-N201 is a module that only supports band 5. But you mentioned that you were able to connect to the network before, so that should be okay.

Let us know!

Hi Gregory,

I’m using UEUpdateUI, it always timeout as showing in the following picture.

At the same time, I connected another uart port to my pc to check UEUpdateUI command. It sends:
1 ‘AT+NR’ while it shows ‘Trying to reset UE using AT command’
2 ‘efbfbdefbfbdefbfbd0d0d0d’(hex) while it shows ‘Trying to reset UE using bootloader command’;
The module doesn’t response for both commands.

I’m not sure with the bootloader command. But the AT command should be ‘AT+NRB’ right? I also tried directly send AT+NR command to the module which doesn’t reply. But it reboot with ‘AT+NR’ command. Is there another version for this N201?

Best regards,


Can you reboot your pc and try it again? and as administrator?


tried several times, still the same. What’s the idea about rebooting? Is ‘AT+NR’ the valid command?


Hi Kyle,

What Arduino are you using? Did you also try with ‘No Baud Switch’ selected?

I think you’re right about the ‘AT+NR’, not sure why that is though. Another thing you can try is doing a manual reset (with ‘No Baud Switch’ selected or deselected). For this you need to connect the reset with GND, see the image below for the reset-pin of the module:

Do you also have a USB-to-Serial converter? If so, and the Arduino-uploader is still not working, you can try to upgrade the firmware with that one.

Let us know how it goes!

Hi Gregory,

I’m using crowduino for powering and enable nb-iot shield.

I connect two USB-to-Serial converter to NB-IOT shield. One is for ueupdater the other is just for debugging purpose.

Before starting the update process, I send at command to nb-iot shield. It worked as expected. Then I started the update process with ueupdater. While it trying to reboot the device, i tried:
1 send ‘AT+NRB’ to module, it reboots as expected;
2 connect reset pad to ground, it also reboots as expected;

But for both ways, the ueupdater give a mesasge “Unable to verify bootloader connection - try resetting again”.

Still stays the same.


Exactly the same here. Can Sodaq please come with a start-2-finish solution how to do reliable firmware upgrades ? This is highly appreciated.

Regards, Kamiel

Do you also have a serial connection active on the Arduino (besides connecting the two USB-to-Serial)? If you want to upgrade the firmware with a USB-to-Serial connection, the best thing would be to make sure D0 and D1 are set to input on the Arduino (or disable Serial) and only connect one USB-to-Serial converter (to D0, D1, GND).

It could be that any other connection on Serial is messing up the communication when upgrading the firmware, because at that moment it will communicate at 115200 bits/s.

Did you try the upgrade guide from our support page? If so, and something is unclear, please let us know what is unclear and we’ll change it as soon as possible.

Also, please let us know which version of the module you have and what error you are getting (e.g. with a screencapture).


I have the same problem with the UEUploader. Anyone found a solution?


You can follow the steps to upgrade your board here:

Did you try the reset pin gregory mentioned?