N211 - Revert to factory settings / Delete NCDP setting from NVM?

Hi all,

I had been using the NB-IoT shield in UDP mode without any problems with my operator, until I accidentally loaded an example arduino file that configured an address for the NCDP (and maybe some other configurations). Now, after sending the CFUN, COPS and CGDCONT commands, I can connect to the radio network (NUESTATS and CSQ is OK), but I cannot get an IP address (like I would get before).

Before I had not configured anything for NCDP:

Now I get these results:
+NCDP: “”,5683

I suspect that the NCDP setting (or maybe some other setting that went into the NVM) is creating problems for the setup of the PDP for my operator that does not have a NCDP.

Does anyone know how to revert the Non Volatile Memory back to the factory settings?
I have tried flashing firmware, with and without the “write settings” option, but the NCDP address is still there.


Hi all,
For anyone interested I send here an update on this topic.

  • I have contacted u-blox and they said there is no way for me to erase the NVM
  • I tried to run the same commands again (CFUN, COPS, CGDCONT) and now I get an IP address (while there is still a configuration for the NCDP)

Conclusion: the suspicion that the NCDP setting was creating problems for the setup of the PDP was unfounded.
Of course, I would like to know what did cause the problem and why it is working now, but you can’t have everything …