LoRaONE not recognised


I received a LoRaONE and started playing with it.
However, he is not recognized by Windows 10.
When I plug it in USB, nothing happens (no popup or anything).
I tried restarts of PC and reinstalling Arduino IDE Preferences Sodaq boards but it didn’t help.
What might be the problem, how could I load the correct Drivers for Windows?

On my Windows 10 machine it shows up under Ports (COM & LPT) as “Arduino Zero (COMX)”:

If you are seeing it there, try checking in the Arduino IDE under Tools->Port and select the one that matches what is shown in Device Manager.

Another thing you could try is the reset double tap. Pin 6 of the J2 header is the RESET pin. This needs to be grounded to reset the board. To double tap, momentarily ground it twice with a 0.5 - 1.0 second interval. The board should then stay in bootloader mode and will show up with a different COM port number.

Seems to work on my laptop now, no reset was needed. Somehow still not working on my PC, i’ll manually install the drivers later :grin:. Thanks for your response! :sunglasses: