Latest Firmware for NB-IoT shield - Arduino Leonardo

Dear Community
The FW version in my NB-IoT shield is V100R100C10B656, I wish to update it as I’m not able to communicate with the Base Tower. Kindly provide me the FW and the procedure to flash it.

I did email info@sodaq and they advised me to query here.
Thanks in Advance

Hi nav,

For a FW upgrade you’ll have to contact Ublox.

Once you have it, you can follow the instructions as written for the other boards. You’ll need to write/get a passthrough sketch working.

Kind regards,

1 Like

Hi @nav117,

We have sold the NB-IoT shield in the past with different N2 modules.
Which one do you have?
Can you send the command ATI9 to show the current version?
You can use the passthrough command to send this command: Passthrough - SODAQ Support pages
This sketch also needs to be loaded when you want to update the module.
You need to update the module in the correct order.

Best regards,

Dear @Jan
I deeply apologies for the delay.
I have a Deluxe variant shield with SARA-N211 chip.

ATI9 Commands throws ERROR
AT+CSCON=1 gives OK but AT+CEREG=5 gives ERROR and the same for following commands too under Vodafone UDP setup. I use Vodafone sim and started right from Step one under Vodafone UDP. I use Arduino serial monitor to send commands.

I tried contacting Ublox but unable to get a reply, could you help me with the firmware.

Thanks for your extended support :grinning:

Hi @nav117 ,

N211, that’s the best one (the others were single band)
I see you already contacted the info email. I will search your ticket and send you a reply there with all required attachments.

You can find the passthrough here:
Passthrough - SODAQ Support pages

The required steps (other board, same module) can be found here:
Overview - SODAQ Support pages

Since ATI9 doesn’t work you must have a firmware before A07.
Please do the updates in the correct order.

Best regards,

1 Like

Dear @Jan
Thank you very much for the instant support.

Dear @Jan
I get this error : Failed : Timed out trying to establish connection in UEupdaterUI

Shield is on top of Leonardo board and connected to USB port of computer.

I restarted my computer post UEupdater installation. Tried to reset the shield and Leonardo board using its reset buttons. Also tried in CLI using UEUpdater.exe updateall --in sara-N211-02X-00.fwpkg --port com6.

Unable to connect to the board.

Dear @nav117 ,

I just checked the notes I had from the past. The Leonardo is too slow :frowning:
It cannot handle the high update baudrate.

If you have any board with a SAMD microcontroller then I know it will work fine. We sell the following board in our webshop with the Arduino Form-factor:
SODAQ Explorer
Crowduino m0

Board like the Arduino Zero, Arduino m0 should also work fine.

Best regards,

1 Like