KPN OTAA issues

I was wondering if there is anyone around who has successfully connected SodaqOne board to the Dutch KPN LoRA network using OTAA?
Even when I’m using the SodaqOne-UniversalTracker-v2 firmware from Github I’m not able to join the network. (the joinrequest is seen in the ThingPark portal, but the SodaqOne doesn’t receive a response to my joinrequest)

However I can connect to KPN successfully using ABP.
I’m also able to connect to The Things Network using both ABP and OTAA.

Things I’ve tried so far:

  • The firmware of the RN2483 module is upgraded to 1.0.3
  • I’m close enough to the gateway. Tried different gateways. Even drove close to them to get a better signal.

Debug log:


mac join otaa
[expectString] (“ok”) .–> “ok” found a match!
[expectString] (“accepted”) …–> “denied”

I’m not directly looking for a solution, but I would like to hear success stories from other users to be able to work towards a solution.

Meanwhile we’ve figured out the problem. We reconfigured the entire ThingPark account and after that everything worked fine.

1 Like