Issue with updating R410M firmware (can't access PWR_ON pin)


I am currently trying to update firmware on Sara R410M-02B-00 module on Sara AFF board (rev 3). I’m using the USB socket that is by the R410M module, not one that’s by the SIM holder.

Current firmware version is L0., A.02.01. and I would like to update it to the latest (L0.,A.02.04) version. I have already received the firmware file and Easy Flash from u-Blox.

I have already tried the update procedure listed on Sodaq site ( and it doesn’t work for me. After contacting u-Blox support I was given the following instructions:
• install EasyFlash
• reboot PC
• put the firmware file in the EF installation directory
• open EasyFlash with administrative rights
• selected R4 and USB in EasyFlash, left baudrate empty
• turn off the module -> “start” in EasyFlash -> Easyflash will prompt “turn on the module”-> turn on the module-> hit power on button
• then the FW update should start

Since the power on (PWR_ON) pin is controlled directly by Sodaq board itself, I can’t follow through with the instructions and it makes little sense to contact u-Blox further regarding the issue.

How can I approach this issue?

Note: I also tried to update the firmware using two other PCs, one with Windows 10, and other with Windows 7.

If it’s of any help, a screenshot with error that occurs in EasyFlash is given below.

Hi @symbi,

Disconnect all power sources.
Connect the USB.
Double press the reset button, this will set the microcontroller in bootloader mode.
The sketch won’t start and will therefor not try to also connect to the modem.

Open EasyFlash as administrator, and follow the instructions from u-blox.

Best regards,

1 Like

Thank you @Jan, it worked perfectly. For future reference, in this case ‘to turn on the module’’ one must connect to modem’s USB port after microcontroller is already in bootloader mode.

Best regards :slight_smile:

1 Like