How to recover bricked RN2903 on ExpLoRer?

I have an ExpLoRer and unfortunately I have managed to erase the RN2903 firmware while trying to upgrade to a newer version and I am now looking for any guidance on how to flash the firmware.

Long story short, I came across 2 approaches for updating the RN2903 firmware:

  1. Microchip LoraDevUtility
  2. Sodaq RN2xxx Firmware Updater

I tried the Microchip tool first. For it to work I loaded a serial pass through sketch to the board to allow the tool to directly communicate over serial with the RN2903. It all started beautifully - the tool recognized the module, performed a sys firmware erase and then the serial communication link failed, aborting the upgrade. From that point on there is no firmware on the RN2903 so my attempts to flash it have been futile.

I was hoping the Sodaq Firmware Updater might save my bacon, but alas it also does not work since it cannot communicate with the module.

Is it possible to flash the module with a debugger? I am familiar with using a PICkit3 to flash the firmware on a Microchip Lora Mote. I don’t see access to the module’s ICSP pins on the ExpLoRer, so at the moment I am thinking this option is not available.

Any help would be greatly apperciated!

[quote=“snelson, post:1, topic:732”]
I was hoping the Sodaq Firmware Updater might save my bacon, but alas it also does not work since it cannot communicate with the module.
[/quote] After uploading the sketch, do a power cycle.
When not detected in normal mode, do a power cycle and retry in bootloader mode.
When successful, do a power cycle to the board.

Power cycle: disconnect any battery / usb / power source for 5 seconds.

There is a Tag Connect available to reprogram the module with a PICkit

Hope you will get it back to live!


I had not heard of Tag-Connect before now. I’ve ordered a cable from them and should be back in business soon.

I was unable to get it into bootloader mode with the Firmware Updater. Absolutely no response from the module. I hosed it good, real good!

Thanks for the advice,

Hello again.

Is there any special setting required to enable the tag-connect interface on the board?

Over many, many attempts I have been unable to connect using Microchip ICD3 and this cable

I am using MPLAB IPE with device type set to PIC18LF46K22. The displayed programmer error indicates that the device is not detected.

For power to the LoRa module I have tried both powering it with the ICD3 at 3.3V and the MicroUSB port.

Yesterday, a co-worker confessed that he had also bricked his RN2903 with the Firmware Update sketch. I gave him the tag connect hoping for different result, but unfortunately it did not work for him either. He had ordered a debugger cable directly from Microchip that is yet to arrive, so we have our fingers crossed that perhaps there is a pinout issue with the one I have.

Please let me know the results.

Hi, I have had a similar problem on a different board, I was updating the firmware to the RN2903 and part way through the communication link failed and i have been unable to reestablish a connection. Did you find a solution in the end?

Hi @asarge,

You can recover it by using the PIC kit with a TAG Connect cable.

Best regards,