Failing to add device to AllThingsTalk

Today I tried to start with AllThingsTalk. I signed up for an account.
Then I tried to connect a device to a newly created ground. I gave the Sodaq NB-IoT shield a name and for the Activation Code I used the 8 capitals on the box of the NB-IoT shield GB…
Unfortunately I got the error: “Device is already activated in network or activation code is not valid.”

Does anyone have a clue what I could do now?
I have no device in my list.

Can you please contact All Things Talk about your issue.

Thanks Jan. I contacted them. I got the fast answer that I should send my question to, which I did. But I did not yet receive an answer.

@Nikola_Petkovic can you help him?

Hi @Jan

I tried to troubleshoot @nico218a issue, but it seems to be on your side.
Please update this thread accordingly.

Hi @Nikola_Petkovic

Thanks for helping us to solve this issue. :slight_smile:

Thanks Jan and Nikola,

The activation with the new code was successful.

Best regards,

Hi Jan and Nikola,

After waiting for more than one day to get messages coming through in AllThingsTalk, I am wondering if I should do more than is described in the tutorial?
I activated the device, made an asset and filled in a decoding function. Nothing seems to arrive. I tried two of the examples and I also twice connected the device manually to the network without problem. And I have sent a message manually.
The debug functions keeps saying “no messages”.

Did I forget something?
Any help would be appreciated.

I found my mistake.
I added the decoding function of the example to my single asset.
But I did not understand I should make an asset for each asset name in the decoding function.
When I did this, messages started to come in. In debug, there was no message of rejected messages.

I got this clue from this blog:

In there is the tip:
Asset name is case sensitive! So check asset against the payload conversion function asset name.