Difficulty Uploading Sketch - SODAQ SARA AFF R410M

@Jan - Greetings! we have purchased a SODAQ SARA AFF R410M R2 board in the Arduino Footprint. We have soldered headers onto the board in the understanding that it is in the arduino form factor, clearly it must be intended to be mounted directly onto an arduino UNO.

We have the sketch from this page loaded in the IDE, we have the boards loaded into boards manager.We worked all day today in order to start experimenting with AT commands, but we have not been able to make it work using any of the methods below:
We have tried a number of different approaches.

Method 1: Upload Sketch to Arduino R3. The board is not recognized (we believe because we are using the SARA board selection, not the Arduino Uno). The result returned is:

> Set binary mode
> No device found on COM11
> Send auto-baud
> Set binary mode
> An error occurred while uploading the sketch

Method 2: We connect the USB cable directly to the SODAQ board. There is no device recognized in device manager, and no driver for it. Site says to contact UBLOX or SODAQ to obtain it.

Method 3: Power the SARA board directly and attempt to connect to TX/RX directly with FTDI cable to establish UART serial communication at 115,200 and send AT commands.

@jan ourQuestions are:
- for the sketch shown on the website, which method of connection is the correct one?
- if it is #1, are there any special instructions to load onto UNO R3?

  • if it is #2, can you please email or post the driver for the USB connection?
    - if it is #3, are there any additional requirements (pins set high or low) to get UART comms?

Thank you. I’m sure we are missing something simple. We see other posts of issues, but we do not see that others have had this particular problem.

Kind Regards,

The SODAQ SARA AFF board is intended to work stand alone.
It is compatible with the Arduino Zero.
If you have 3.3V Arduino shield, you can use these on top of our board.

Make sure you use the latest Arduino IDE
Follow the steps on this page:
Install at least the SODAQ SAMD boards.
Restart your pc to finish the driver installation.

When the SODAQ Board still isn’t recognized install the Arduino SAMD m0 boardfiles.
These files install the drivers for the Arduino Zero, which has the same microcontroller as the SODAQ SARA AFF.
Again you may need to restart your pc to finish the installation.

When you still don’t have a connection.
Double press the reset button on the board, this should result in a fading led.

In the Arduino IDE, when selection the port, the name behind the port will be the first SAMD board in the list.
If Arduino m0 files and SODAQ files installed your pc will think it’s an Arduino Zero.

To uopload the sketch to the board:
Please remove any attached board, use it first stand alone.
Connect to the usb of the SODAQ Board.
When uploading to the sketch, Select SODAQ SARA from the list.
Check if you upoad to the correct port.
And upload :slight_smile:

Hope this explains a bit more clear.
Let me know if you get it working.

Best regards,