Dargino development kit.. config problem with arduino

I have purchased the new LoRa IoT development kit for development purpose. But I have problem in regards to the configuration. I have followed the steps of the manual provided but when i tried the I.P the page is not loading and when i tried the first blink program its not uploading too and have error…

processing.app.debug.runnerexception at cc.arduino.packages.uploaders.ssh uploader.uploadusingpreferences(sshuploader.java:145) at cc.arduino.uploaderutils.upload(uploaderutils.java:78) at processing.app.sketchcontroller.upload(sketchcontroller.java:732) at processing.app.sketchcontroller.exportapplet(sketchcontroller.java:703) at processing.app.editor$defaultexporthandler.run(editor.java:2030) at java.lang.thread.run(thread.java:748) caused by: com.jcraft.jsch.jschexception: java.net.connectexception: connection timed out: connect at com.jcraft.jsch.util.createsocket(util.java:389) at com.jcraft.jsch.session.connect(session.java:215) at cc.arduino.packages.uploaders.sshuploader.uploadusingpreferences(sshuploader.java:117)

I have no clue how to get rid of this. for the first time, the IP address does work but before i configure, the internet LAN was not connected so I tried the connections and restart the device. After thats, nothing is working.

Kindly provide me suitable way to configure the development kit.
Thank you in advance.

Rakeh Saleem

Dear @Rakeh_Saleem,

What Dargino board / gateway are you using? I prefer a url :slight_smile:
What SODAQ board are you using?[quote=“Rakeh_Saleem, post:1, topic:1917”]
I have followed the steps of the manual provided
Can you tell me what manual? Then I can check it.

Kind regards,


Thank you for reply,
Following is the link of dragino kit I am using and the manual provided according to which I initiated the task to boot and config for the first time.

So, during my first bootup i didn’t managed to config it properly, beacause of which in first time I made connection between lora node and LG01 gateway but their was no internet access. Then I read that I have to config the dragino LG01 gateway to wifi client mode. And in doing so, I made some changes afterwards, my device became invisible againn and again. I have tried several times but I have NO idea what am I dojng wrong.
The steps which I have seen in most datasheets and guides are to config this ways.

But after following these steps, the router doesn’t config properly. One thing to have in mind, For this config I had to set IP address manually in my PC and afterwards I don’t have internet access so I could not properly save these changes and neither can i upload to online cloud storage.

I hope you understand my problem. kindly give me some suggestion to config my dragino LG01 device properly.
That would be very helpful.

M. Rakeh Saleem

Dear @Rakeh_Saleem,

I am not familiar with the LoRa Dragino kit / gateway.
You should get in touch with them to get the best support.

Kind regards,

Hey there, I have the same problem as your’s. I was wondering if you can help me, if you were able to sort it out.
Thanking you in anticipation :slight_smile:

Hello Misbah, Hope you are doing well.

Back in the days, when I had the same problem I figured out that the issue was related to the configuration problem. I solved the issue by their customer help center and the person responded and tried solve my issue related to the configuration. Can you be more specific what are you facing… Is the problem related to the configuration or some other issue ?


Below steps were followed and the issue related to it was resolved… I hope it helps and still faces any problem you can contact the help person… He might help you in more detail.

The LG01 has a fall-back ip in its LAN port. This IP is always enabled so user can use fall back ip to access LG01 no matter what the WiFi IP is. The fall back ip is useful for connect and debug the unit.

(Note: fallback ip can be disabled in the LAN and DHCP page)

Steps to connect via fall back IP:

  1. Connect PC’s Ethernet port to LG01’s LAN port
  2. Configure PC’s Ethernet port has IP: and netmask:

Attached image for reference

  1. In PC, use to access LG01 via Web or Console.


Thank you so much!!
God bless you, i will try this, i hope it helps.
Actually i got this kit from my teacher, and it had password changed so i reset the router to configure it again. It was accessible at ip before resetting it But since i have reset the router, its ip is not loading. And i came across your question. haha! Anyway thankss :’)

I hope it helps and resolve your issue.
Cheers !!