Board not responding

I’ve got two SARA R412M boards. The first one works properly, the other one doesn’t respond to commands like ‘ATI9’ or any other AT+ command (the other one responds with: M0.05.00,A.01.05).
Is there a way to try and (re)install the firmware, just to make sure it isn’t caused by the software, instead of the hardware? Or is there anything else I can try to figure out what might cause this problem?
I already tried the passthrough sketch, but I can’t see anything in the screen after I enter a command (not my own, and no response).
Thanks in advance!

Hi @jamesbond,

Please send an email to info at sodaq dot com
With a request for the new firmware for the R412M module.
You will get then Ublox their EasyFlash tool and latest firmware.

Let me know if this helped to let your board work properly again.

Best regards,

Hi @Jan, thanks for sending me the firmware for the R412M.
I followed the tutorial (link:, but got the following response:

Using USB port
Processing 'SARA-R412M-02B M0 10 00 IP.dof'
Please TURN ON the device and don't disconnect power supply
Waiting for device...

Please TURN OFF and then TURN ON the device
Waiting for device...
Error occured!
[Can't find device!]

Please TURN OFF the device and press 'Start' to install the firmware

I connected the board using the USB port on the side that says ‘USB SARA module’. I also tried to connect the other USB port to battery that used to power the device (using the port next to the LTE-M SIM slot), but that isn’t working.
EasyFlash (which I ran as admin.) wasn’t able to detect the device using the following settings:

Is there something I’m missing?
Thanks in advance!

Hi @jamesbond,

Upload an empty sketch.

Disconnect everything.

Connect the data cable to the SARA USB side.
Connect a 2nd USB cable next to the SIM slot.
Connect the LiPo.

Restart the EasyFlash as administrator.
Run the update.

If you still have issues, do you see the Qualcomm port in the devicemanager?

Best regards,

Hi @Jan,

Thanks for your quick reply.
Unfortunately, I’ve tried it using your instructions (except the LiPo step, because we haven’t powered the board using a battery or anything, we’re using a powerbank that is connected to the USB-port (next to the SIM-slot)), but it doesn’t work.

I’ve also checked the COM5 port in my Windows Device Manager (Qualcomm HS-USB Diagnostics 900E), and there are no warnings, the driver is enabled.

Is it possible to perform the reset/firmware-install without LiPo, as you stated in your previous explanation? The error in EasyFlash is exactly the same as it was in my reply this morning (see the image above).

Do you have any idea what I can try next?
Thanks again for your time, I really appreciate it.

Hi @jamesbond,

It seems you do everything correct.
Did you reboot your pc after installation of EasyFlash?

Unfortunately I have seen more people who do not get the update tool working.
You can contact the webshop about swapping the device for an updated board.

Best regards,