Autonomo: USB device not recognized


I had autonomo connected to pc and lipo battery was connected to the board as well.
All was fine but now when I plug autonomo to usb it says usb device not recognized.
When I plug only lipo battery board is not running - it seems to, app was there was
flashing user led.

I tried to reset board as was already suggested in the forum but it did not helped.

Any suggestions?


The Autonomo is programmed and communicates with the host PC via the native USB component of the SAMD21 processor. If the board is put to sleep, or a badly formed sketch is uploaded, this can cause the processor to become unresponsive.

One solution is to enter the bootloader mode. To enter bootloader mode, press the reset button twice with about a half second interval between the resets. You will then have to wait a couple of seconds and then the board should appear, but on a secondary COM or TTY port. Do not press the reset a third time as this will reset the board in normal mode.

Double press worked. COM6 appeared and I uploaded sketch again (not sure if I should).
Unfortunatelly now even COM6 is not recognized.

It should be back on COM5 after you finish uploading the sketch.

The device uses two separate COM ports. It normally appears on the primary one (COM5) and then switches over to the secondary port (COM6) during the upload process, then it switches back. If you put the board in bootloader mode it stays on the secondary port (COM6) until the board is programmed or reset.

In the Arduino IDE you can set the preferences to show you debug output of the upload process.

Yes, I uploaded blink and have com5 back. thank you. R.