Autonomo Sleep?

I am looking for a way to put Autonomo into proper “low power sleep” (&RTC wakeup)
There are examples for other boards but I havent found one for Autonomo:

Any takers? :wink:

There is an example included with the RTCZero library which configures the alarm system and puts the board into sleep mode.

The RTC (in Calendar mode) can wake the board at regular intervals using the alarm system (which generates an interrupt). The most frequent alarm is once a minute.

If you use the latest test board files v1.6.8, the IO pins are no longer all set to INPUT as default. This resolves the issue of the current leakage from the IO pins, which reduces the current down to the region of 35-40uAs when in sleep mode. Running the RTC with a configured interrupt will increase that figure.

Additionally, another 25uAs can be saved by putting the data flash chip into a deep sleep as well. However, the process takes a bit more work.

1 Like

in my boards manager I have two SAMD options - 32 bit ARM Cortex-M3 which has version 1.6.8 available and also 32 bits ARM Cortex M0+ which only has v 1.6.6

I thought M0+ was the correct one as I get the following compiler message

Warning: platform.txt from core ‘SODAQ SAMD (32-bits ARM Cortex-M0+) Boards’ contains deprecated"{compiler.path}{}" {} {} “{build.path}/{archive_file}” “{object_file}”, automatically converted to"{compiler.path}{}" {} {} “{archive_file_path}” “{object_file}”. Consider upgrading this core.

Certainly don’t want to be losing power unnecessarily. Can you point me to which manager I should be using. Thanks

The official board manager release can be accessed with the following added to the preferences dialog:

The current release version is 1.6.7

There is a newer version 1.6.8 which has yet to be officially released. The URL for the test version is:

You can ignore that warning. I believe that warning is also shown when building for the Arduino Zero board.

Edit: I should add that v1.6.7 was a major update bringing many improvements from the main Arduino SAMD core. For the Autonomo, v1.6.8 has only one minor change which removed the code which set all the digital IO pins to INPUT as default. This was to improve power efficiency by minimising current leakage.

I have tried adding the test json package but versions 1.6.7 and 1.6.8 do not appear as options. Only 1.6.6.

You need to add the URL to the preferences under “Additional Boards Manager URLs:”, as shown here:

Then in the boards manager you can filter by “sodaq”:

I had done exactly that before - which is why I’m struggling. I imagine this is a bug in the IDE. I have tried a reboot and an uninstall of the SAMD board but so far no success. I guess the next step is to reinstall the IDE (v1.6.8)
OH cancel that - I was confused between the Arduino SAMD board and the Sodaq SAMD board. I’ve now updated the Sodaq version. Sorry for the trouble.