Autonomo not recognised


I received Autonomo and LoraBee Dev kit few days ago and started playing with it.
Today suddenly Autonomo stopped being recognized by Windows 8.1 and on Windows XP as well.
When I plug it in USB I see “Ünknown USB Device” and “USB Device descriptor failed”.
I tried restarts of PC and reinstalling Arduino IDE Preferences Sodaq boards but it didn’t help.
What might be the problem , how could I load the correct Drivers for Windows ?

Thank you,


Hi Vasil,

Due to the Autonomo using the native USB port, certain errors can cause the board to become unresponsive to the USB host. Unfortunately, this types of errors (bad sleep code, badly configured registers etc) can be encountered directly after resetting the board.

Please try resetting it via the SWD port. I have given some instructions in this thread:

Thank you Gabriel !

Do I make the grounding , just by shorting for couple of seconds the two neighbor pins on SWD port (RST and GND ) as they are next to each other or it is more complicated ?



Any GND pin will do. I normally attach a jumper wire to GND and then tap the RST pin a couple of times.

Thank you Gabriel ,

I reset it following your instructions , than loaded correct sketch and now it works fine.

Have s great day !