Autonomo, can't get IDE to work properly

I haven’t used my Autonomo for a while, and now I have a new project for it, I noticed the board had dropped from my board list. So I tried to reinstall from the url and the library Sodaq SAMD boards by Sodaq.

However, when I try to install version 1.6.8 I get an error “The CRC does not match, the file is corrupt”. So I installed version 1.6.7

But when I do that, I see an error in the bottom IDE window: “Invalid version found: v1.0.2” appearing multiple times. The Autonomo does show up in the board list, and I can select it properly. But when I compile my sketch, it says

Board sodaq_autonomo (platform samd, package SODAQ) unknown

Error while compiling.
Invalid version found: v1.0.2
Invalid version found: v1.0.2
Invalid version found: v1.0.2
Invalid version found: v1.0.2

Anyone knows what this error is and what I am doing wrong? My IDE version is 1.6.7

There seems to be an issue with the listed CRC for v1.6.8.

For now can you try the following URL:

Thanks! problem is solved. By the way the “Invalid version found: v1.0.2” error message had nothing to do with the board support package problem. It was another library I had installed that generated this warning message…


Can we have the link updated please to include

sodaqsamdboards-1.6.14.tar.bz2 which i think is the latest.

SODAQ engineers!
please work on the same page guys, wake up!

Having multiple json files is a pain for us users.

Plus a guide that does not work for some, puts folk of the kit. is my guide here.



Hi Mark,

If you like you can email me at and I can possibly provide you with some assistance with the ExpLoRer board.

1 Like