AT+CFUN =1 returns Error 4 (SOLVED)

Hi everyone,

I recently got my Sodaq NB-IoT Shield with Crowduino M0 ( I also used this sketch ( to pass AT commands to ublox module (02B SARA N211). However, not all AT Commands work. For example, AT+CFUN=1 returns error code 4 (not supported) when other commands to acquire version or change some configurations of module return OK. AT + CIMI returns just OK without displaying IMSI of SIM (i use a test sim card). AT+CPIN? returns Error !

In order to make AT+CFUN=1 to work, i tried to upgrade firmware using UEUpdater UI but everytime installation gets stuck at “Trying to reset UE using…” while using the forementioned sketch to pass AT commands (tried both 9600 and 115200 baud rates, rebooting, run as administrator etc. ).

Is anyone else having this problem and know any solution so that module can work correctly ?

Thanks in advance.


Did you try the manual reset?

Best regards,

I haven’t tried this yet. Once I have, I will get back to you.

1 Like

Hello Jan,

Manual reset while updating solved the problem and I was successful upgrading firmware to version 6.57.

The cause for AT+CFUN=1 returning ERROR seems to be my test SIM card. I tried using a SIM card of a mobile carrier and it returned OK. In both cases, NB-IoT module was not registered to network.

Anyone know why my LTE test SIM card doesn’t work but that of a mobile carrier does ? I have info of my Anritsu Test SIM and my mobile carrier’s SIM as it is shown using an android app. (test SIM) (mobile carrier’s SIM)


Your mobile sim needs to support nb-iot.
In the Netherlands regular sims don’t work.

When you obtain a nb-iot supported sim you need to have nb-iot coverage.
The N211 can be used on Band 8 and band 20 depending on your operator.

To send a message you have to know if your operator uses UDP or CoAP

Best regards,


Thank you for your reply. I am aware of that. The NB-IoT UE is going to connect to my own SDR-based NB-IoT femto cell. I just need to make AT+CFUN=1 to work with my Test SIM card the same way it did work with my mobile carrier’s SIM card. I don’t want to register to any NB-IoT network for now, just the AT+CFUN=1 command to work. In addition, my mobile carrier’s SIM doesn’t support NB-IoT, it is just a regular SIM card and AT+CFUN=1 worked with that regular SIM card without registering to NB-IoT or LTE network (AT+CEREG? returned 0, not connected).

I want to have the same functionality with my SIM test Card and I can’t figure out why it works with mobile carrier’s SIM card but not with my Test SIM card. Once I make AT+CFUN=1 work, I can configurate SDR software and UE database files so that SODAQ UE registers to my own NB-IoT femto cell.

Keep in mind that since SDR is used, I am both network operator and user. Therefore after AT+CFUN=1 returns OK which is just full radio functionality of ublox module enabled, I will make UE register to my NB-IoT network.

What type of SIM must I insert in SODAQ NB-IoT Shield for that ? USIM , CSIM or ISIM ?

Thank you for your time.

Problem was solved when a 1.8V Test SIM Card was used. My previous 3V/5V SIM card did not work!