Arduino 1.8.4 IDE and ExpLoRer setup

Hi all

Has anyone got the Arduino IDE 1.8.4 to work following the guide?

I get errors from the IDE saying error json file not found.

So, I can no longer pick the SODAQ ExpLoRer from the IDE.
Loaded last week before the kit arrived.

Tried guide now with Arduino IDE 1.8.4 its broken for me.

If I am an IDIOT, please say so.

Found a new link on the forum for folk to link with.

Thanks for reading




fixed my issues with boards not showing up.

But it is an old version, I think!


Its all broken SODAQ DEV team, please fix your build and guide.


link found, might also need looking at DEV team.


CRC is a total different issue and already solved.

Update 2
On the support pages for the Explorer we refer to the new samd url.
Please let me know if you see an old url, for the mbili/moja and others still used.

Update 3.

The IDE can not find the Sodaq Boards.
You actualy will have two !!

Go to %localappdata% -> Arduino15\packages\SODAQ\hardware\samd
Remove the old version.

Happy programming :slight_smile:


1 Like


I have followed your new instructions.

What is the latest version to use please state here for users?

I removed both 1.6.11 & 1.6.14 and reinstalled as you said.
So now i can pick the board.

IDE says now 1.6.11 installed!

It goes into boot mode BLUE flashing light and i upload an example program.
It uploads. IDE says OK.

Then i unplug and look for other USB port.

The new port appears now.
I select it set to 9600 LFCR

But now i see nothing on the debug.
Any more clues on this BLACK MAGIC to get it working.

Do you have a full guide showing the process?
It would be cool to have a SODAQ working guide.

Thanks loads for helping.

UPDATE FIXED with SODAQ engineers advice remove old files in Arduino.

Sorry for cross-linking subjects.


Happy days under Atmel Studio 7 with SoDaQ ExpLoRer

Code running just need me pins soldered on the board, buqqer!
My fingers are so fat, my eyes so sore.

Thanks for all the advice given here in this forum.

Thanks, SoDaQ engineers, full team for your support also.

Also hats off to the MICROCHIP team for responding to request to fix Atmel Studio sign in, updates are now active for new installs.

People, please think about moving to Atmel Studio 7 if you can.

My ICE is now on order.


Happy Mark

PS Kudos best company forum I have been on for many a year.

1 Like